Returning status code 403

Mar 15, 2012 at 5:59 PM

I am implementing the presence controls, but the presence is graded out. I have some doubts. When i use fiddler to debug it it is returning status code 403. The description of response code is “Application Pool Access Denied. The specified request cannot be executed from current Application Pool”. The server in which the html presence.service is running is having certificates installed. My doubt is "Is this application pool access denied error occurs if the service cannot contact web server? The service is running under domain account. Do i need to use the certificates in the code? Please correct me if i am wrong. Thanks!

Coordinator
Mar 16, 2012 at 3:40 PM

I didn't have to deal with certificates when deploying this.  Did you follow the deployment steps where it details setting up your application pool?  Specifically, what identity did you assign to the pool?

Mar 19, 2012 at 2:05 PM

The Application pool is running under a domain account. I followed the steps mentioned in documentation for setting up the application pool. Is HTML Presence Controls.service communicating with the Lync server? If so does this need any other access? Also i have created a trusted contact URI, its showing offline. I dont know the reason why it is always showing offline. I sthe issue is because of this trusted contact showing offline?

Mar 21, 2012 at 5:42 PM
Edited Mar 22, 2012 at 10:38 AM

I got this error when i checked in the log files

Platform End startup threw an exception One or more values in the configured settings are invalid or unusable. Check inner exception and logs for more details.   at Microsoft.Rtc.Signaling.SipAsyncResult`1.ThrowIfFailed()

   at Microsoft.Rtc.Signaling.Helper.EndAsyncOperation[T](Object owner, IAsyncResult result)

   at Microsoft.Rtc.Collaboration.Samples.HTMLPresenceControls.Service.Common.UcmaHelper.PlatformStartupCompleted(IAsyncResult result) in C:\htmlpresencecontrols-77189\src\HTMLPresenceControls.Service\Common\UcmaHelper.cs:line 295

Inner Exception:

The settings wrapper failed to initialize.

Unable to find  the Sqld database: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

   at Microsoft.Rtc.Internal.ServerConfiguration.UCSettings.InitConsumerWithRole(RoleName role, Boolean throwIfFailed)

   at Microsoft.Rtc.Internal.ServerConfiguration.UCSettings..ctor(String applicationId, SettingsWrapperOptions options)

   at Microsoft.Rtc.Internal.ServerConfiguration.UCSettings.Get(String applicationId, SettingsWrapperOptions options)

   at Microsoft.Rtc.Collaboration.ProvisioningSourceImpl.GetInitialPlatformData()

Coordinator
Mar 21, 2012 at 6:35 PM

Do you have your trusted application pool configured properly?  It doesn't appear so, the UCMA application is not even starting...